STALKERSOUP


Everything about the STALKERSOUP game...
 
HomeFAQRegisterLog in
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Latest topics
» Patch 1.10015 now available to auto-update
by _Nite_ Today at 13:32

» The '100 Rads' bar...
by pchester Yesterday at 22:44

» The mercenary Bolt's PDA
by pchester Yesterday at 22:01

» Resetting anomalies?
by nemisis1842khann Yesterday at 15:55

» Makarov 'Special' PM
by pchester Yesterday at 9:51

» Navigating the teleports in Lab X-10
by Sword2012 Sat 14 Oct 2017 - 12:30

» Finding the entrance to the Labyrinth
by Sword2012 Sat 14 Oct 2017 - 12:27

» Discord Server
by Artyom Sat 14 Oct 2017 - 4:26

October 2017
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     
CalendarCalendar
Top posting users this week
pchester
 
Sword2012
 
merkak134
 
_Nite_
 
TecnoBacon
 
nemisis1842khann
 
Statistics
We have 225 registered users
The newest registered user is waddlesmcsqueezy

Our users have posted a total of 2444 messages in 228 subjects
Who is online?
In total there are 3 users online :: 1 Registered, 0 Hidden and 2 Guests

Ripped306

Most users ever online was 22 on Fri 13 Oct 2017 - 10:55

Share | 
 

 Patch 1.10015 now available to auto-update

View previous topic View next topic Go down 
Go to page : 1, 2  Next
AuthorMessage
Sword2012
Administrator
avatar

Posts : 236
Join date : 2017-05-31
Location : UK

PostSubject: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 1:38

Yay! Thank you TB and Aleks1970
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 8:40

That was way quick, what was changed? looks like its time to start another playthrough

edit: I noticed that DX11 sweet fx got changed to DX11 extended, and its working. a bit of a boost to the graphics
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 11:21

Thanks Aleks1970 & TB.

Note: Error on launching game:

"Could not find file 'stalkersoup\bin_dx11_extended\xrgame_ss.dll'."

Solved by copying xrgame_ss.dll across from \bin_dx11_sweetfx\ folder.
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 12:18

pchester wrote:
Thanks Aleks1970 & TB.

Note: Error on launching game:

"Could not find file 'stalkersoup\bin_dx11_extended\xrgame_ss.dll'."

Solved by copying xrgame_ss.dll across from \bin_dx11_sweetfx\ folder.

thats interesting I never had that error when launching the game in that mode, but I did have it when I tried to change the field of view in that mode

I moved that file though so thanks for that
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 15:02

Has anyone had a problem restarting after shutting down Stalkersoup 110015 + DX11 Extended? I am getting a CTD with a LUA error when "...Entering the Zone...". Changing to plain DX11 lets me start the game. Change back to DX11 Extended and I get the CTD.

FATAL ERROR

[error]Expression    : fatal error
[error]Function      : CScriptEngine::lua_error
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line          : 73
[error]Description   : <no expression>
[error]Arguments     : LUA error: ...es\stalkersoup\gamedata\scripts\tb3d_services.script:261: attempt to call global 'log1' (a nil value)

I don't know if this is because I used the xrgame_ss.dll from the SweetFX folder. Has anyone else seen this?
Back to top Go down
TecnoBacon
Administrator
avatar

Posts : 46
Join date : 2017-06-01
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 18:24

I have updated the xr_core, xr_game and the renderer dll files, you need the new ones from the dx11 folder. I have noticed that not all installations get updated properly, especially win10. it appears to be access rights with the ss_update.exe file. Aleks1970 is on a 2 week hiatus so any update problems will need to be tackled by the forum. Please anyone who knows how to set a user to use admin rights in win10 properly help us out.
Back to top Go down
http://tecnobacon.com
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 20:08

TecnoBacon wrote:
I have updated the xr_core, xr_game and the renderer dll files, you need the new ones from the dx11 folder.

Thanks TecnoBacon, that worked. For anyone else having the same DX11 Extended problem, I copied:

xrCore.dll
xrgame.dll
xrgame_ss.dll
xrRender_R1.dll
xrRender_R2.dll

from the bin_DX11 folder to the bin_DX11_extended folder and I can now use DX11 Extended mode again.

Sorry, can't help with Win 10, I am on Win 7.
Back to top Go down
kd6dm
Moderator
avatar

Posts : 90
Join date : 2017-06-03
Location : Northern California

PostSubject: Re: Patch 1.10015 now available to auto-update   Tue 3 Oct 2017 - 22:51

I'm running Win 10, and my game updated OK, except for the xrgame_ss.dll not being copied. (Copied it from bin_DX11 folder...thanks pchester) BUT, I don't run the update from the installer due to past access issues. I run it from the STALKERSOUP\Resources\Updates folder after the download portion of the Updater is finished. Right-click it and chose "Run as administrator".

To change a standard user account to administrator, do the following:

Administrator Account:
 

For more info, see: [You must be registered and logged in to see this link.]

After any update, I always run "Take ownership" just to be sure. Not positive it's needed, but it doesn't hurt.

_________________________________________________
One shot, one kill.
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 4 Oct 2017 - 0:01

pchester wrote:
Has anyone had a problem restarting after shutting down Stalkersoup 110015 + DX11 Extended? I am getting a CTD with a LUA error when "...Entering the Zone...". Changing to plain DX11 lets me start the game. Change back to DX11 Extended and I get the CTD.

FATAL ERROR

[error]Expression    : fatal error
[error]Function      : CScriptEngine::lua_error
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line          : 73
[error]Description   : <no expression>
[error]Arguments     : LUA error: ...es\stalkersoup\gamedata\scripts\tb3d_services.script:261: attempt to call global 'log1' (a nil value)

I don't know if this is because I used the xrgame_ss.dll from the SweetFX folder. Has anyone else seen this?

not here, I did a fresh install of stalkersoup 110012 and updated it to 110015, and DX11 extended is working for me.

I recommend ya do a fresh install too pchester cause I know ya like to edit the files alot to fix them between versions
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 4 Oct 2017 - 9:54

_Nite_ wrote:
I recommend ya do a fresh install too pchester cause I know ya like to edit the files alot to fix them between versions

Thanks _Nite_, you are probably right. It has been a while since I did a complete reinstall. I am near enough to the end to want to finish my current game, then I will start over.
Back to top Go down
da_raabi
Experienced
avatar

Posts : 69
Join date : 2017-06-17
Location : Florida

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 4 Oct 2017 - 14:35

Sweet! I come home from running from a hurricane to find a stalkersoup update! Does it get any better than this??? Welcome home to me!
Back to top Go down
Artyom
Experienced


Posts : 75
Join date : 2017-07-11

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 4 Oct 2017 - 16:58

Yes, the patch is making the game much more stable! Very Happy
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Thu 5 Oct 2017 - 4:08

I noticed that too, 110015 is a heck of alot more stable, I havn;t had an out of memory crash once yet and i been all over back and forth many times across the maps
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Thu 5 Oct 2017 - 9:56

a few things I noticed so far in 110015

Spoiler:
 
Back to top Go down
TecnoBacon
Administrator
avatar

Posts : 46
Join date : 2017-06-01
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Thu 5 Oct 2017 - 16:57

thanks, I will check these out, saves always help me with explanation as to what you are trying to do and what did not work when you send saves
Back to top Go down
http://tecnobacon.com
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Thu 5 Oct 2017 - 18:01

_Nite_ wrote:
- when I have night vision on, anytime I access my inventory or an enemys inventory then exit, it turns off the night vision. (this might be a suit specific issue, I currently have the regular Stalker suit that barman gives ya)

I get the same issue with night vision turning off. Updated game to 110015 but still playing a 110014 game. Currently using the blue nano suit with White Night NV, also tried the Monolith exo with Cats Eye NV and Scientific suit with green PNV, same result.
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Fri 6 Oct 2017 - 1:16

TecnoBacon wrote:
thanks, I will check these out, saves always help me with explanation as to what you are trying to do and what did not work when you send saves

I ussually do but I figured these were noticeable problems already since they are early into the game
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Fri 6 Oct 2017 - 11:56

is the FN 2000 Compact gun still in 110015?

edit: nevermind found one.


Last edited by _Nite_ on Sat 7 Oct 2017 - 8:14; edited 1 time in total
Back to top Go down
kaplumbaga
Experienced
avatar

Posts : 137
Join date : 2017-06-14
Location : turkey

PostSubject: Re: Patch 1.10015 now available to auto-update   Fri 6 Oct 2017 - 14:54

this patch didnt fix disappear urchin thorrns artifacts problem.
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sat 7 Oct 2017 - 10:18

found a Nil Value CTD in this version, it happened just as I exited the game. (not gamesave or mission specific)

-->BSTALK:  net destroy

FATAL ERROR

[error]Expression    : fatal error
[error]Function      : CScriptEngine::lua_error
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line          : 73
[error]Description   : <no expression>
[error]Arguments     : LUA error: d:\stalkersoup\gamedata\scripts\bind_stalker.script:333: attempt to index global 'TB3D_Triggers' (a nil value)


stack trace:
Back to top Go down
TecnoBacon
Administrator
avatar

Posts : 46
Join date : 2017-06-01
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sat 7 Oct 2017 - 20:13

_Nite_ wrote:
found a Nil Value CTD in this version, it happened just as I exited the game. (not gamesave or mission specific)

-->BSTALK:  net destroy

FATAL ERROR

[error]Expression    : fatal error
[error]Function      : CScriptEngine::lua_error
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line          : 73
[error]Description   : <no expression>
[error]Arguments     : LUA error: d:\stalkersoup\gamedata\scripts\bind_stalker.script:333: attempt to index global 'TB3D_Triggers' (a nil value)


stack trace:

odd, I have been using triggers all the time so something is very wrong here, make sure you do not have a dbv1 after you update to 0015
Back to top Go down
http://tecnobacon.com
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Sat 7 Oct 2017 - 21:28

Have just done a clean install for the first time in ages. Can someone please remind me how to turn off the intro movie so I jump straight to the menu screen?
Back to top Go down
Sword2012
Administrator
avatar

Posts : 236
Join date : 2017-05-31
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Sat 7 Oct 2017 - 23:34

pchester wrote:
Have just done a clean install for the first time in ages. Can someone please remind me how to turn off the intro movie so I jump straight to the menu screen?
In the Game Launcher, under 'Game Manager' Smile
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 1:46

TecnoBacon wrote:
_Nite_ wrote:
found a Nil Value CTD in this version, it happened just as I exited the game. (not gamesave or mission specific)

-->BSTALK:  net destroy

FATAL ERROR

[error]Expression    : fatal error
[error]Function      : CScriptEngine::lua_error
[error]File          : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line          : 73
[error]Description   : <no expression>
[error]Arguments     : LUA error: d:\stalkersoup\gamedata\scripts\bind_stalker.script:333: attempt to index global 'TB3D_Triggers' (a nil value)


stack trace:

odd, I have been using triggers all the time so something is very wrong here, make sure you do not have a dbv1 after you update to 0015

I just checked I don't have that file, I'm using a fresh install of 110012 and updated it to 110015

This error was only a 1 time occurance btw, not seen it any other time yet

other then this I only had the DV on entry CTD, and occasionally C stack CTD;s so this version has been alot more stable for me.
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 10:10

Sword2012 wrote:
pchester wrote:
Have just done a clean install for the first time in ages. Can someone please remind me how to turn off the intro movie so I jump straight to the menu screen?
In the Game Launcher, under 'Game Manager' Smile

Aaargh! Thank you. I knew it was an easy fix, but I just couldn't find it. Rolling Eyes
(Nice to see you all dressed in red, by the way. cheers )
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 10:24

_Nite_ wrote:
this version has been alot more stable for me.

Agreed. I am not far into my new game, but I am seeing very few 'transition' crashes so far. Still getting an occasional CTD if the game writes a delayed save when I am doing something else, but I am learning to be patient and wait for the 'save' message before moving on.

The only minor annoyance for me has already been reported - night vision switching off whenever I enter an inventory screen.

Overall, this update has been a big improvement. Well done TecnoBacon, Aleks1970 and all others involved. cheers
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 11:03

yea and the other minor annoyance is not being able to do the techs mutant detect mission cause of no military PDA's, so ya want to get the Bioradar as soon as possible to see where they are.

pchester wrote:
Sword2012 wrote:
pchester wrote:
Have just done a clean install for the first time in ages. Can someone please remind me how to turn off the intro movie so I jump straight to the menu screen?
In the Game Launcher, under 'Game Manager' Smile

Aaargh! Thank you. I knew it was an easy fix, but I just couldn't find it. Rolling Eyes
(Nice to see you all dressed in red, by the way. cheers )

Red and Green, its like christmas colors when I see you and swords posts now, even though its only october wtf scratch  lol
Back to top Go down
TecnoBacon
Administrator
avatar

Posts : 46
Join date : 2017-06-01
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 18:33

I found a bug in the DX11 startup in the amk_mod first start that is not switching completely so it is using DX9 config with the DX11 shaders. This in no way effects the game other than making it darker in shadows and brighter in sunlight.
I have also discovered that the net_packet_pda fix to support the live-link player mode has made the PDA services in my TB3D_Services obsolete. My solution to this is to allow all NPC to get their personal PDA and randomly give Military NPC the special Military PDAs. When you take a personal PDA it will trigger a new method that logs the dead NPC name and removes the PDA from your inventory. Only quest PDAs will remain in your inventory until task is complete. Military PDA will show in your inventory and will still be used for the geeks.
Back to top Go down
http://tecnobacon.com
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Sun 8 Oct 2017 - 22:41

I wondered about that, I had to keep the weather on default since it always rained on that mode and keep it darker, I couldn't use cloudy (which is what I prefered) on this version cause when the sun came out it was too overbright
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Mon 9 Oct 2017 - 14:40

Sakarov bag not located in chernobyl on 110015, this seems to be a common problem on and off across different game versions and playthroughs I done, I sent aleks my gamesave

edit: nevermind this post, I wen't back to the location again after completing wish granter and the doctors bag was thier.


Last edited by _Nite_ on Tue 10 Oct 2017 - 13:15; edited 1 time in total
Back to top Go down
chucksar
Novice


Posts : 9
Join date : 2017-06-12

PostSubject: Re: Patch 1.10015 now available to auto-update   Mon 9 Oct 2017 - 16:45

what I've experienced in 1.10015 new playthrough so far

Spoiler:
 
Back to top Go down
da_raabi
Experienced
avatar

Posts : 69
Join date : 2017-06-17
Location : Florida

PostSubject: Re: Patch 1.10015 now available to auto-update   Mon 9 Oct 2017 - 17:00

chucksar wrote:
what I've experienced in 1.10015 new playthrough so far

Spoiler:
 

If NPCs won't talk to you, try firing a few rounds off nearby. Sometimes that will make them "jump" and you can talk to them. If you are brave you could also try shooting them directly. Do this at your own risk Twisted Evil

Also, if you happen to have a mutant embryo (or just spawn one) you can use it to spawn a blind dog or something nearby. This will definitely get the NPCs to move. I did this in the bar... It was fun.
.
.
.
I would just recommend you do not spawn a controller or something. He might kill the NPC! lol!
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 11 Oct 2017 - 1:29

I still can't do the doctors missions at pripyat on 110015, everytime I pickup the book in the theater I get the setbonevisible CTD
Back to top Go down
pchester
Moderator
avatar

Posts : 453
Join date : 2017-06-03
Location : UK

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 11 Oct 2017 - 11:05

_Nite_ wrote:
I still can't do the doctors missions at pripyat on 110015, everytime I pickup the book in the theater I get the setbonevisible CTD

You could try spawning it in (item sak_book4 under Cordon) and see if that crashes. I haven't reached Pripyat yet, but as a test I just warped to 'pripchurch' and spawned the book. No crash, and doc appeared as usual.
Back to top Go down
_Nite_
Veteran


Posts : 312
Join date : 2017-07-13
Location : USA

PostSubject: Re: Patch 1.10015 now available to auto-update   Wed 11 Oct 2017 - 11:45

pchester wrote:
_Nite_ wrote:
I still can't do the doctors missions at pripyat on 110015, everytime I pickup the book in the theater I get the setbonevisible CTD

You could try spawning it in (item sak_book4 under Cordon) and see if that crashes. I haven't reached Pripyat yet, but as a test I just warped to 'pripchurch' and spawned the book. No crash, and doc appeared as usual.

ok I will try that

besides this problem though I freaking love the stability of 110015 its making the missions go alot faster for me, made alot of progress today.
Back to top Go down
Sponsored content




PostSubject: Re: Patch 1.10015 now available to auto-update   

Back to top Go down
 
Patch 1.10015 now available to auto-update
View previous topic View next topic Back to top 
Page 1 of 2Go to page : 1, 2  Next
 Similar topics
-
» Patch 1.10014 now available to auto-update
» NEW: The English Patch for Hollywood Monsters (Pendulo Studios,1997).
» WoW china is back+need to update to 3.1.3+new realmlist
» Fix for Patch Update: Tuesday March 01
» Doom 2 update patches, backup folders, and manuals

Permissions in this forum:You cannot reply to topics in this forum
STALKERSOUP :: STALKERSOUP Main discussions-
Jump to: