STALKERSOUP


Everything about the STALKERSOUP game...
 
HomeFAQRegisterLog in
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Latest topics
» Sakharov's bag at NPP
by vf14 Today at 6:57

» Backpack bursting. Shoddy goods?
by vf14 Today at 6:53

» X-16 Kostya stash.
by vf14 Today at 6:21

» UPDATE 110017
by Gery D. Today at 2:26

» Too easy game - make harder
by sjohnson Today at 0:45

» Error message and help/support subforum
by Iceddeadmeat Yesterday at 23:03

» The '100 Rads' bar...
by Warezz.K Yesterday at 17:13

» Aggression bug triggered in X18?
by sjohnson Mon 18 Jun 2018 - 23:30

June 2018
MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
252627282930 
CalendarCalendar
Top posting users this week
vf14
 
TecnoBacon
 
sjohnson
 
Alphabet Soup
 
Warezz.K
 
pchester
 
TomaszTheOctopus
 
Gery D.
 
Iceddeadmeat
 
Statistics
We have 521 registered users
The newest registered user is jackaller

Our users have posted a total of 6039 messages in 685 subjects
Who is online?
In total there are 3 users online :: 1 Registered, 0 Hidden and 2 Guests

vf14

Most users ever online was 26 on Sat 7 Apr 2018 - 5:10

Share | 
 

 A new 16.1 patch?

Go down 
AuthorMessage
joy division
Experienced
avatar

Posts : 88
Join date : 2017-06-07
Location : Italy

PostSubject: A new 16.1 patch?   Wed 3 Jan 2018 - 17:56

The Updater says that there's a new patch 16.1.
What's new?
Back to top Go down
pchester
Moderator
avatar

Posts : 1253
Join date : 2017-06-03
Location : UK

PostSubject: Re: A new 16.1 patch?   Wed 3 Jan 2018 - 18:14

[You must be registered and logged in to see this link.] wrote:
Updater says that ther's a new patch 16.1.
What's new?

It's just a quick fix by Aleks1970 for a problem someone had encountered. See Aleks' post in this thread: [You must be registered and logged in to see this link.]

Posted by TecnoBacon a couple of days ago:
quote=[You must be registered and logged in to see this link.]:
 
Back to top Go down
papanoel
Novice


Posts : 26
Join date : 2017-06-03
Age : 39
Location : France

PostSubject: Re: A new 16.1 patch?   Thu 4 Jan 2018 - 22:31

I get a CTD when entering the bar territory and loading both my hardsave and the autosave. Error type is "setbonevisible". Latest micropatch has been installed.
As I've been able to enter this territory yesterday I suppose there's a "bad" object in a trader's inventory.
Oh and by the way, before updating my game I had the same CTD when equiping the M16 Sniper rifle.
Back to top Go down
pchester
Moderator
avatar

Posts : 1253
Join date : 2017-06-03
Location : UK

PostSubject: Re: A new 16.1 patch?   Thu 4 Jan 2018 - 22:51

[You must be registered and logged in to see this link.] wrote:
I get a CTD when entering the bar territory and loading both my hardsave and the autosave. Error type is "setbonevisible". Latest micropatch has been installed.
As I've been able to enter this territory yesterday I suppose there's a "bad" object in a trader's inventory.
Oh and by the way, before updating my game I had the same CTD when equiping the M16 Sniper rifle.

I had the same problem. In my case it was because I had copied an edited file (items.ltx) from the previous version into my new gamedata folder. The game uses any files that it finds in \gamedata\ instead of the 'master' versions in the main game files, so it was using my old file instead of the new, updated items.ltx. Deleting the old file solved the issue for me. (I think I had to leave the Bar map and return for it to take effect.)
Back to top Go down
papanoel
Novice


Posts : 26
Join date : 2017-06-03
Age : 39
Location : France

PostSubject: Re: A new 16.1 patch?   Fri 5 Jan 2018 - 1:14

[You must be registered and logged in to see this link.] wrote:
[You must be registered and logged in to see this link.] wrote:
I get a CTD when entering the bar territory and loading both my hardsave and the autosave. Error type is "setbonevisible". Latest micropatch has been installed.
As I've been able to enter this territory yesterday I suppose there's a "bad" object in a trader's inventory.
Oh and by the way, before updating my game I had the same CTD when equiping the M16 Sniper rifle.

I had the same problem. In my case it was because I had copied an edited file (items.ltx) from the previous version into my new gamedata folder. The game uses any files that it finds in \gamedata\ instead of the 'master' versions in the main game files, so it was using my old file instead of the new, updated items.ltx. Deleting the old file solved the issue for me. (I think I had to leave the Bar map and return for it to take effect.)

Thanks for the tip. I didn't modify any file so it seems unlikely that it is the source of the crash.
Back to top Go down
pchester
Moderator
avatar

Posts : 1253
Join date : 2017-06-03
Location : UK

PostSubject: Re: A new 16.1 patch?   Fri 5 Jan 2018 - 10:30

[You must be registered and logged in to see this link.] wrote:
Thanks for the tip. I didn't modify any file so it seems unlikely that it is the source of the crash.

Clutching at straws here, but did you start a new game ('Enter the Zone') to create an updated all.sav file before continuing your current game?

Otherwise I am sorry, I don't know. All I can suggest is that you either send your save game files (.dds and .sav), with an explanation, to TecnoBacon (stalkersoup@tecnobacon.com) and see if he can identify the problem, or do a full reinstall and see if that fixes it.

My usual caveat: I am not the best one to answer installation/update questions, so perhaps someone else here can suggest something more helpful.
Back to top Go down
papanoel
Novice


Posts : 26
Join date : 2017-06-03
Age : 39
Location : France

PostSubject: Re: A new 16.1 patch?   Sat 6 Jan 2018 - 13:30

[You must be registered and logged in to see this link.] wrote:
[You must be registered and logged in to see this link.] wrote:
Thanks for the tip. I didn't modify any file so it seems unlikely that it is the source of the crash.

Clutching at straws here, but did you start a new game ('Enter the Zone') to create an updated all.sav file before continuing your current game?

Otherwise I am sorry, I don't know. All I can suggest is that you either send your save game files (.dds and .sav), with an explanation, to TecnoBacon (stalkersoup@tecnobacon.com) and see if he can identify the problem, or do a full reinstall and see if that fixes it.

My usual caveat: I am not the best one to answer installation/update questions, so perhaps someone else here can suggest something more helpful.

Yes, I started a new game. Twice actually as the first time I had a CTD when loading my latest save (error message was : invalid parameter).

I tried again after applying the 16.2 patch. I still get the same CTD.
I guess it has something to do with one or more object in my stash as my game crashes when approaching this area.
I  have 2 stashes at the northern part of the bar along with some anomalies I spawned using capsules.
There is a stash for weapons and another one with ammo, artifacts, suits, food, etc.
I suppose the latest main patch changed an object model which is causing the crash.

Last lines of the error log are:
! auto-generated bump map: arsenal_mod\ak74_detail1_bump#
! auto-generated bump map: arsenal_mod\ak74_detail1_bump
! auto-generated bump map: arsenal_mod\ak47_bump#
! auto-generated bump map: arsenal_mod\ak47_bump
stack trace:

0023:0046E4C6 XR_3DA.exe, CKinematics::LL_SetBoneVisible()
Back to top Go down
pchester
Moderator
avatar

Posts : 1253
Join date : 2017-06-03
Location : UK

PostSubject: Re: A new 16.1 patch?   Sat 6 Jan 2018 - 14:11

[You must be registered and logged in to see this link.] wrote:
I suppose the latest main patch changed an object model which is causing the crash.

Last lines of the error log are:
! auto-generated bump map: arsenal_mod\ak74_detail1_bump#
! auto-generated bump map: arsenal_mod\ak74_detail1_bump
! auto-generated bump map: arsenal_mod\ak47_bump#
! auto-generated bump map: arsenal_mod\ak47_bump
stack trace:

023:0046E4C6 XR_3DA.exe, CKinematics::LL_SetBoneVisible()

I think you are right. Those lines appear to refer to the arsenal_mod, which is one of the weapon mods under config\weapons\. If you have weapons in your stash that have been modified in the mod files, it could be creating a conflict. As a last resort, you may need to work back through earlier saves until you find one without the problem weapon/s (if that is what it is) in your stash. Do you have a save from when you first entered the Bar that you can use as a test?

Sorry if I have asked this before, but have you tried changing check_bad_weapons = false to check_bad_weapons = true in your tb3d_modders.script? TecnoBacon introduced this to use in cases of 'bone' crashes.

Is there anything in the FATAL ERROR section at the end of the log file to suggest which file is actually causing the error? For example, this was for a different crash, but it told me to look at line 948 in file tb3d_process_levels.script:

FATAL ERROR
<snip>
[error]Arguments     : LUA error: stalkersoup\gamedata\scripts\tb3d_process_levels.script:948: attempt to index global 'TB3D_Mobs' (a nil value)


If there is nothing there that helps, I suggest that you send your save game files to TecnoBacon with an explanation of the problem. Hopefully he will be able to identify and fix whatever is wrong.
Back to top Go down
Aleks1970
Administrator Founder
avatar

Posts : 102
Join date : 2017-05-31
Age : 48
Location : Slovenia

PostSubject: Re: A new 16.1 patch?   Sat 6 Jan 2018 - 21:17

[You must be registered and logged in to see this link.] wrote:
...

Last lines of the error log are:
! auto-generated bump map: arsenal_mod\ak74_detail1_bump#
! auto-generated bump map: arsenal_mod\ak74_detail1_bump
! auto-generated bump map: arsenal_mod\ak47_bump#
! auto-generated bump map: arsenal_mod\ak47_bump
stack trace:

0023:0046E4C6 XR_3DA.exe, CKinematics::LL_SetBoneVisible()

Please tell me the name of equipped weapon for this error.
Back to top Go down
http://stalkersoup.forumotion.me
papanoel
Novice


Posts : 26
Join date : 2017-06-03
Age : 39
Location : France

PostSubject: Re: A new 16.1 patch?   Sat 6 Jan 2018 - 21:22

I loaded an earlier save in the bar before updating to 1.0016. Got the very same error.
What puzzles me is the fact that I've been able to enter the bar map after applying the 16 patch. Maybe the error has been brought on by the 16.1 patch ?
I also checked the errorlog and found no reference to a particular file.

Aleks1970 requested a save so I'll send it to him.

Quote :
Please tell me the name of equipped weapon for this error.

HK UMP-45 Tactical or BOAR-12.
Back to top Go down
joy division
Experienced
avatar

Posts : 88
Join date : 2017-06-07
Location : Italy

PostSubject: Re: A new 16.1 patch?   Sun 7 Jan 2018 - 21:27

A new 16.2 patch is available...
Back to top Go down
Sponsored content




PostSubject: Re: A new 16.1 patch?   

Back to top Go down
 
A new 16.1 patch?
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
STALKERSOUP :: STALKERSOUP Main discussions-
Jump to: